5/5 - (7 votes)

In the last few days, all Joomla users are excited with the official release of Joomla! 5 which comes with an array of cutting-edge features that are set to redefine your Joomla website building and management experience. However, should you upgrade Joomla! 4 to Joomla! 5 when you are using our Joomla! templates? The blog today will include the answer with a detailed explanation. Let the journey begin!

General information about Joomla! 5

After the successful release of Joomla! 4 two years ago, the highly anticipated Joomla! 5 version is set to be officially launched on October 17, 2023. Excitingly, this new version will bring a plethora of advanced features, including optimized code, enhanced security measures, faster loading speeds, and more efficient website management capabilities. To delve deeper and gain comprehensive insights into the remarkable new features of Joomla! 5, simply navigate here.

It’s unforgettable that the upgrade process from Joomla! 3 to Joomla! 4 was implemented two years ago. It was quite an involved undertaking, requiring meticulous migration and careful attention to prevent any data loss. Moreover, users had to adapt to the all-new interface of Joomla! 4, which differed significantly from the previous Joomla! 3. However, the transition from Joomla! 4 to Joomla! 5 will be far simpler and less time-consuming, as there won’t be any significant alterations to the admin interface.

Should You Upgrade Joomla! 4 To Joomla! 5 Now 1

If your intentions involve updating from Joomla! 4 to Joomla! 5, it is imperative to ascertain that your current Joomla version is no lower than Joomla 4.4.0. It is pivotal that you first uplift your site to Joomla 4.4.0 before proceeding further with the transition to Joomla! 5.0. This sequential process ensures a smooth and seamless upgrade.

How to upgrade Joomla! 4 to Joomla! 5

At present, our responsive Joomla! templates are powered by Joomla! 4.2.8. Fear not, for we have curated a seamless two-step process for an effortless upgrade from Joomla! 4 to the all-new Joomla! 5. Firstly, let’s update Joomla! 4.2.8 to Joomla! 4.4 and then update Joomla! 4.4 to Joomla! 5.0.

Update Joomla! 4.2.8 to Joomla! 4.4

The process of updating from Joomla! 4.2.8 to Joomla! 4.4 will be smooth and fast without any errors. Now, all you need to do is go to your Joomla admin dashboard, press on the System option, and click on Joomla 4.4.0 in the Update part.

Should You Upgrade Joomla! 4 To Joomla! 5 Now 2

The pre-update check for Joomla 4.4.0 presents itself as your trusty ally in assessing the readiness of all components for an update. Once diligently inspected, a single click on the “Acknowledge the warnings concerning potentially incompatible extensions and move forward with the update” option shall unveil the gateway to progress. Rest assured, clarity resides in the tap of the Update button, initiating a seamless transformation.

Should You Upgrade Joomla! 4 To Joomla! 5 Now 3

Our extensive testing of Joomla! templates reveal a seamlessly smooth updating process from Joomla! 4.2.8 to Joomla! 4.4, with zero errors or hiccups. Rest assured, you can confidently undertake this task without any concerns of jeopardizing your data or encountering any unpleasant surprises.

Update Joomla! 4.4 to Joomla! 5.0. Do you need to do that now?

Upgrading Joomla from version 4.4 to 5.0 is a task that requires careful consideration. If you are currently utilizing our Joomla templates, you may wonder that do you need to upgrade Joomla! 4 to Joomla! 5 now.

Are you ready to embark on the journey of upgrading Joomla! 5.0? Before you dive into the process, it’s imperative to confirm that your website is in perfect harmony with the following technical prerequisites. Let’s ensure your site is equipped to conquer the digital realm with the utmost professionalism.

  • PHP: 8.1
  • MySQL: 8.0.13+
  • MariaDB: 10.4+
  • PostgreSQL: 12+

In the latest update of Joomla 5, some exciting enhancements have been made to boost your website’s performance and reduce errors. Fontawesome 6.4 and Codemirror 6 have been integrated, along with an updated Webauthn Library. Embracing these technical advancements will ensure that you experience optimal performance and minimize any chances of errors. It’s time to adapt to these technical requirements above and take your website to new heights!

After checking the technical requirements, it’s time for you to decide whether should you upgrade Joomla! 4 to Joomla! 5 now. There are 3 choices for you to consider:

  • First of all, with our normal Joomla! templates built based on Helix Ultimate Framework, you can seamlessly transition from Joomla! 4 to the newest version hassle-free. Whenever a new version of Helix Ultimate is available, you will receive a notification in the Joomla control panel. Then smoothly upgrade your Joomla! 4.4 to Joomla! 5.0. Before taking the plunge, don’t forget to review the technical requirements for a flawless and triumphant upgrade.
  • Secondly, when utilizing Agethemes’s eCommerce Joomla templates, it is essential to check the compatibility of the eCommerce extensions with Joomla 5. In other words, before upgrading from Joomla 4.4 to Joomla 5.0, it is imperative to ensure that the eCommerce extension authors have the latest version that is compatible with Joomla 5. If a compatible extension is available, it should be updated before the upgrade. However, if the eCommerce extensions are not yet compatible with Joomla 5, it is recommended to continue using Joomla 4.4 and wait for the latest version that works well with Joomla 5. Currently, Hikashop is adaptable to Joomla 5, but there is no information for Virtuemart and J2Store.
  • Finally, if you use our Joomla! templates alongside third-party functional extensions like Solidres for booking purposes, it is advisable to reach out to the authors of said extensions and inquire about a Joomla! 5 compatible version. Once you have confirmed the availability of a compatible version for the extension, feel at ease to proceed with updating the extension before progressing to the update of Joomla! 4 to Joomla! 5.

Some Helix Ultimate and Pagebuilder Font Awesome 6 issues. How to solve them?

When Joomla users upgrade Joomla! 4 to Joomla! 5, they may see the following issues.

The menu arrow icons issue is here.

Update Joomla 4 To Joomla 5

And the rating star icons in a single post issue is here.

Upgrade Joomla 4 To Joomla 5 Img2

To deal with the two issues above, there are solutions for you to follow.

Adding code to deal with the issues

Option 1: To fix this issue, you need to log in to your admin dashboard -> Click on System -> Templates-> Site Templates -> [template-name] Details and Files -> Open index.php file, at line 129, please add font-awesome.min.css. See image below

3

Option 2: Access the admin dashboard. Go to System -> Site Template Styles.

Upgrade Joomla 4 To Joomla 5 Img3

Click on the active template you are utilizing -> Template Options.

Upgrade Joomla 4 To Joomla 5 Img4

Visit Custom Code -> Custom CSS -> Add the following code:

Code for solving the menu arrow icons issue:

.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent>.nav-header>.menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent.menu-parent-open>.nav-header>.menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent.menu-parent-open>a>.menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent.menu-parent-open>.menu-separator>.menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent li.menu-parent .menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent>a>.menu-toggler:after,
.offcanvas-menu .offcanvas-inner ul.menu>li.menu-parent>.menu-separator>.menu-toggler:after,
body.ltr .sp-megamenu-parent .sp-dropdown .sp-dropdown-items .sp-has-child>a:after,
body.ltr .sp-megamenu-parent>li.sp-has-child>a:after,
body.ltr .sp-megamenu-parent>li.sp-has-child>span:after,
.chzn-container.chzn-container-single .chzn-single div>b:after,
.article-ratings .rating-symbol span.rating-star,
#modal-menu ul.sp-megamenu-parent li.sp-has-child>a:after,
#modal-menu ul.sp-megamenu-parent li.sp-has-child>span:after,
.header-modules .search form:after {
font-family: "Font Awesome 6 Free";
}

Code for solving the rating star icons in a single post issue:

.article-ratings .rating-symbol span.rating-star
{ font-family: "Font Awesome 6 Free";}

Updating Fonts File to solve the issues

First of all, you need to download and unzip the Fonts File Package.

In the next step, you are freely able to upload the Fonts File via File Manager (for VPS or Hosting with FTP/SFTP support).

If you need to upload the Fonts File via FTP, simply open your hosting cPanel -> create an FTP account -> link to your website folder (normally it’s the “public_html” folder). After that, let’s browse your local drive to upload from the Local Site window on the left. Now, simply drag the files to an appropriate folder in the Remote Site on the right, /var/www/html/[site-name]/templates/[template-name]/fonts

If your hosting supports cPanel, it’s simple for you to go to cPanel -> File Manager, open your website folder and upload the Fonts File with the folder path we introduced to you above.

Some Icon & Background image doesn’t show on SP Page builder 5 issues issues. How to solve them?

To fix this issue, you need to log in to your admin dashboard -> Click on Components > SP Page Builder > Pages > Page needs to be edited for icon
Go to Section > click the edit Features box. Then set the size for the icon and Save.

Av

For the background image problems, if you don’t see the same display as the sample Demo, please go to Section > Tab Style > Background and choose the Image tab.

Sp Page Builder Pro Imp Administration 2023 11 17 10 28 43

Wrap Up

All in all, should you upgrade Joomla! 4 to Joomla! 5 now? The answer depends on your Joomla! templates you are using. However, before you strap on your upgrade boots, it’s crucial to consider the type of Joomla! templates you’re currently rocking. The ultimate key lies in diligently verifying that all third-party extensions are in perfect sync with Joomla! 5. This checking ensures a smooth transition from Joomla! 4 to the latest and greatest Joomla! 5.

Leave a Reply

Your email address will not be published. Required fields are marked *

Summer Sale Enjoy your purchase with 50% OFF on today! code: SUMMER2024 More Details
Summer Sale Enjoy your purchase with 50% OFF on today! code: SUMMER2024 More Details